Error:failed to find Build Tools revision 19.1.0

Error:failed to find Build Tools revision 19.1.0
Install Build Tools 19.1.0 and sync project

Android Studio 에서 module을 import하는 중에 위와 같이 build tools를 새로 설치하라는 에러가 났다면, 가이드대로 build-tool 설치한 후에  다시 import를 하자.

‘상위버전(내 경우는 21.1.2)이 설치되어 있는데 하위버전(19.1.0)이 필요한가?’ 라는 생각할 수 있는데, Android SDK Build-tools는 지금까지 버전을 올리면서 변경사항이 많았다. 그래서, 하위 호환이 보장되지 않을 수 있다. SDK Tools나 Platform-tools와는 다르게 지금까지 제공한 Build-tools를 모두 제공하고 있으니 그냥 설치해주도록 하자.

참고로, Android Studio 기준으로 Build-tools를 설치하는 경로는 “Tools > Android > SDK Manager” 이다.

Untitled

댓글 남기기

이메일은 공개되지 않습니다.

이 사이트는 스팸을 줄이는 아키스밋을 사용합니다. 댓글이 어떻게 처리되는지 알아보십시오.